gLite > gLite 3.2 > glite-LFC_oracle > Update to glite-LFC_oracle 3.2.1-0  
 
 

 

 

gLite 3.2

glite-LFC_oracle - Update to version 3.2.1-0


Date 08.02.2010
Priority Normal

Description



glite-LFC_oracle

This patch introduces the glite-LFC_oracle metapackage for gLite 3.2

This is version 1.7.3 for both the LFC and DPM. It contains bug fixes for both services with respect to version 1.7.2, in particular:

  • Bug 53568, which could cause the DPM's SRM 2.2 server to crash
  • Bug 50686, which meant a malformed request could crash the LFC or the DPNS

Other issues which may be noticed by users or administrators:

  • DPM will now only publish information regarding static spaces to the information system, rather than information about all spaces.
  • dpm-listspaces reports space in units of powers of 1024 for normal user use, to be consistent with other DPM tools. When providing data for the information system quantities are reported in SI units, as required by the glue schema.

The xrootd plugin for ALICE for the DPM has been upgraded to version 2.1.0. As previously, in order to enable xrootd access the xroot daemons must be obtained separately - they are not included in the glite release. Plugin 2.1.0 is intended for use with xrootd-20090729.0855, see: https://twiki.cern.ch/twiki/bin/view/LCG/DpmXrootAccess21

The updated xrootd base is expected to bring increased stability to the service. The DPM plugin is also has updated defaults for some settings, extra authentication settings and uses the most recent ALICE security plugin. See the CHANGES and RELEASE files in the CVS repository for a complete list of changes.

DPM Known issues:

For those upgrading from DPM 1.6.x please check the following for known issues and considerations relating to the database schema change: https://twiki.cern.ch/twiki/bin/view/LCG/DpmVersion170SchemaChange

In case the DPM gridftp fails to startup with the error message:

Starting dpm-gsiftp: /etc/sysconfig/dpm-gsiftp says NO: [FAILED]

please check that your /etc/sysconfig/dpm-gsiftp contains the line:

RUN_DPMFTP="yes"

(for configuration files built from the 1.6 template this setting is missing)

glite-ARGUS, glite-BDII, glite-CREAM, glite-LFC_mysql, glite-LFC_oracle, glite-MPI_utils, glite-SCAS, glite-SE_dpm_disk, glite-SE_dpm_mysql, glite-TORQUE_client, glite-TORQUE_server, glite-TORQUE_utils, glite-UI, glite-VOBOX, glite-WN

New release of yaim core

New release of yaim core containing a set of bug fixes and new features:

  • New SAGA adapters. There's a new function called config_glite_saga that configures the SAGA gLite adapters.
  • grid environment cleaning mechanism to be able to install different WN tarball versions in the same machine.
  • Variables that were wrongly implemented in previous yaim releases are now fixed: CONFIG_GRIDMAPDIR and USER_HOME_PREFIX.
  • YAIM doesn't fail when gLite version package is not installed. This is useful for non gLite software using YAIM.
  • siteinfo packaging is now fixed (-p option).

New release of glite-version and glue-schema

The new glite-SE_dpm_disk metapackage introduces a new version of:

  • glite-version: new version of glite-version introducing a set of new options to print information about the versions of the installed gLite nodetypes, their architecture and their update number. It still prints information about the gLite release (i.e. 3.2.0).
  • glue-schema: minor update to change GLUE2PolicyUserDomainForeignKey from being mandatory to optional.

These two packages are also part of other services which are also updated to the new versions with this update,as it can be seen in the service detail pages.

This update fixes various bugs. For the full list of bugs, please see list below.

Fixed bugs

Number Description
 #53462 [ yaim-core ] GROUPS_CONF/group.d mechanism seem to fail in config_sw_dir
 #53745 [ yaim-core ] yaim fails if glite-version is not installed
 #53864 [ yaim-core ] Add SAGA & gLite adapters

Updated rpms

Name Version Full RPM name Description
bdii 5.0.4-1 bdii-5.0.4-1.noarch.rpm bdii
edg-mkgridmap 3.0.0-1 edg-mkgridmap-3.0.0-1.noarch.rpm A tool to build the grid-mapfile
fetch-crl 2.7.0-2 fetch-crl-2.7.0-2.noarch.rpm Tool for periodic retrieval of Certificate Revocation Lists
glite-info-generic 2.0.2-3 glite-info-generic-2.0.2-3.noarch.rpm glite-info-generic
glite-info-provider-release 1.0.0-5 glite-info-provider-release-1.0.0-5.noarch.rpm glite-info-provider-release
glite-info-templates 1.0.0-8 glite-info-templates-1.0.0-8.noarch.rpm glite-info-templates
glite-LFC_oracle 3.2.1-0 glite-LFC_oracle-3.2.1-0.x86_64.rpm gLite metapackage (glite-LFC_oracle)
glite-security-voms-api 1.8.12-1.sl5 glite-security-voms-api-1.8.12-1.sl5.x86_64.rpm org.glite.security.voms-api v. 1.8.12.1
glite-security-voms-api-cpp 1.8.12-2.sl5 glite-security-voms-api-cpp-1.8.12-2.sl5.x86_64.rpm org.glite.security.voms-api-cpp v. 1.8.12.2
glite-version 3.2.1-1 glite-version-3.2.1-1.noarch.rpm Shows version information for the installed gLite node types
glite-yaim-core 4.0.11-2 glite-yaim-core-4.0.11-2.noarch.rpm YAIM core package
glite-yaim-lfc 4.0.5-1 glite-yaim-lfc-4.0.5-1.noarch.rpm glite-yaim-lfc module configures 3.0 LFC.
glue-schema 2.0.3-1 glue-schema-2.0.3-1.noarch.rpm LDAP schema files for the GLUE Schema
lcg-dm-common 1.7.3-1sec.sl5 lcg-dm-common-1.7.3-1sec.sl5.x86_64.rpm LCG Data Management common libraries and man pages.
LFC-client 1.7.3-1sec.sl5 LFC-client-1.7.3-1sec.sl5.x86_64.rpm Client side libraries for the LFC
LFC-interfaces 1.7.3-1sec.sl5 LFC-interfaces-1.7.3-1sec.sl5.x86_64.rpm LCG File Catalog Interfaces
LFC-interfaces2 1.7.3-1sec.sl5 LFC-interfaces2-1.7.3-1sec.sl5.x86_64.rpm LCG File Catalog Interfaces
LFC-server-oracle 1.7.3-1sec.sl5 LFC-server-oracle-1.7.3-1sec.sl5.x86_64.rpm LFC Server for an Oracle database backend

The RPMs can be updated using yum via

Service reconfiguration after update

Service must be reconfigured.

Service restart after update

Service must be restarted.

How to apply the fix

  1. Update the RPMs (see above)
  2. Update configuration (see above)
  3. Restart the service if necessary (see above)