gLite > gLite 3.2 > glite-LFC_oracle > Update to glite-LFC_oracle 3.2.6-1.sl5  
 
 

 

 

gLite 3.2

glite-LFC_oracle - Update to version 3.2.6-1.sl5


Date 30.06.2010
Priority Normal

Description



glite-LFC_oracle

New version of LFC oracle v1.7.4

Bug fix release with one new feature:

  • SURLs bulk lookup.

There is also an important bug fix:

  • Number of DB connections can exceed the number of configured threads because of a missing ROLLBACK WORK RELEASE in closedb.
This update fixes various bugs. For the full list of bugs, please see list below.

Fixed bugs

Number Description
 #33693 Man pages for DPM and LFC incorrectly formatted
 #40619 [ yaim-lfc ] Missing variables in yaim lfc module
 #40622 [ yaim-lfc ] Minor improvements on yaim functions
 #45002 init.d script lfcdaemon/dpnsdaemon assumes /home when it shouldn't.
 #52574 [ yaim-lfc ] User CONFIG_USERS when creating lfcmgr user
 #52576 [ yaim-lfc ] Create LFCMGR_USER_HOME variable
 #55339 lfcdaemon/dpnsdaemon restart not working as expected
 #56212 nsrename of files within the same directory results in incorrect nlink value.
 #56619 DPM/LFC: split packaging of shared libraries
 #56630 Inconsistent man location
 #57531 [LFC/DPM] Non standard install permissions
 #57532 [LFC/DPM] Init script issues
 #57533 [LFC/DPM] Don't convert manpages to text format
 #57534 [LFC/DPM] Broken makefile rules
 #60796 SURLs bulk lookup in LFC
 #65514 [LFC/DPM] rewinddir broken

Updated rpms

Name Version Full RPM name Description
bdii 5.0.8-1 bdii-5.0.8-1.noarch.rpm bdii
glite-info-provider-release 1.0.0-9 glite-info-provider-release-1.0.0-9.noarch.rpm glite-info-provider-release
glite-info-templates 1.0.0-11 glite-info-templates-1.0.0-11.noarch.rpm glite-info-templates
glite-LFC_oracle 3.2.6-1.sl5 glite-LFC_oracle-3.2.6-1.sl5.x86_64.rpm Metapackage for glite-LFC_oracle
glite-security-voms-api 1.9.17-1.sl5 glite-security-voms-api-1.9.17-1.sl5.x86_64.rpm org.glite.security.voms-api v. 1.9.16.1
glite-security-voms-api-cpp 1.9.17-1.sl5 glite-security-voms-api-cpp-1.9.17-1.sl5.x86_64.rpm org.glite.security.voms-api-cpp v. 1.9.17.1 GL32
glite-version 3.2.2-1 glite-version-3.2.2-1.noarch.rpm Shows version information for the installed gLite node types
glite-yaim-core 4.0.12-1 glite-yaim-core-4.0.12-1.noarch.rpm YAIM core package
glite-yaim-lfc 4.0.6-2 glite-yaim-lfc-4.0.6-2.noarch.rpm glite-yaim-lfc module configures 3.0 LFC.
lcgdm-devel 1.7.4-6sec.sl5 lcgdm-devel-1.7.4-6sec.sl5.x86_64.rpm LCG Data Management common development libraries and header files.
lcgdm-libs 1.7.4-6sec.sl5 lcgdm-libs-1.7.4-6sec.sl5.x86_64.rpm LCG Data Management common shared libraries
lfc 1.7.4-6sec.sl5 lfc-1.7.4-6sec.sl5.x86_64.rpm CLI for LCG File Catalogue
lfc-devel 1.7.4-6sec.sl5 lfc-devel-1.7.4-6sec.sl5.x86_64.rpm LCG File Catalogue development libraries and header files
lfc-libs 1.7.4-6sec.sl5 lfc-libs-1.7.4-6sec.sl5.x86_64.rpm Client shared libraries for LCG File Catalogue
LFC-server-oracle 1.7.4-6sec.sl5 LFC-server-oracle-1.7.4-6sec.sl5.x86_64.rpm LFC Server for an Oracle database backend
perl-lfc 1.7.4-6sec.sl5 perl-lfc-1.7.4-6sec.sl5.x86_64.rpm Perl interface to LCG File Catalog
python-lfc 1.7.4-6sec.sl5 python-lfc-1.7.4-6sec.sl5.x86_64.rpm Python interfaces to LCG File Catalog

The RPMs can be updated using yum via

Service reconfiguration after update

Not needed.

Service restart after update

Service must be restarted.

How to apply the fix

  1. Update the RPMs (see above)
  2. Update configuration (see above)
  3. Restart the service if necessary (see above)